Can-Am Maverick Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
So I have 95 miles on my maverick now and haven't really been beating on it but at low Rpms like 3000 when I am in high or low and just creeping the belt is making a squealing or like whining noise. Anyone else have this issue or is my belt junk already? It doesn't seem to slip when I get on it tho? Any input? Thanks
 

·
Registered
Joined
·
217 Posts
Never creep around in high its murder on a belt you probably glazed it if your just putt n around or have larger tires always use low
 

·
Registered
Joined
·
121 Posts
Discussion Starter #3
Never creep around in high its murder on a belt you probably glazed it if your just putt n around or have larger tires always use low
I always use low when going slow but I was jUst taking off and was waiting for a buddy to get ahead of me so I took off slow and that's when I realized it was doing it in high too
 

·
Registered
Joined
·
998 Posts
Normal, pretty much all cvt's have some sort of squeal to them pulling out. When I'm in high and just moving it around the garage or yard it'll squeal until it gets up around 10 mph or so.
 

·
Registered
Joined
·
2,964 Posts
Yeah I had the same thing. The belt isn't glazed. Thats what I thought too. It's the primary. Not sure if it's where the sheeves meet up, or if its the "slippery washer". After taking it apart and cleaning the primary up. It quit doing it. Last time out not so much as a squeak out of the clutch. It gets rather annoying since the CVT intake is right up in front of you on the drivers side. I got a CVTech coming...That shouldn't be a problem anymore
 

·
Registered
Joined
·
217 Posts
I had the cv tech installed on mine a few days ago I've had a rhino teryx and a rzr not one squealed except the rhino and that's because i got the belt wet i have noticed can am has a whining that always comes from the clutch area tho
 

·
Registered
Joined
·
998 Posts
Stock can am cvt's are loud, you can watch videos on YouTube and here the cvt's squealing in all the videos
 

·
Registered
Joined
·
121 Posts
Discussion Starter #9
Alright thanks guys. I called the dealer Friday to see if my vin had any open recalls and they said there wAs none. I took it apart just out of curiosity and it all looks good so I'm just going to run it! Thanks again!
 

·
Registered
Joined
·
2,964 Posts
Take an air hose and atleast blow all the black crap out of it. You'll be suprised at how much black dust is in there.
 

·
Registered
Joined
·
806 Posts
While we're on the topic about belts. Has anyone got water in the clutch housing from washing it? Found water in mine and I haven't even been in the deep water yet.
 

·
Registered
Joined
·
2,964 Posts
Had signs of where water had dried up in the bottom of my CVT cover. The only water mine has seen is from the garden hose.....
 

·
Registered
Joined
·
4,536 Posts
Just got done doing 60 miles again today , these clutches make all kinds of lil goofy noises don't worry ! Lol


Sent from my maverick using Tapatalk 2
 

·
Registered
Joined
·
1 Posts
I have same problem with my Maverick after only 40km , the sound happen when in on park and i feed or when im in gear from 0 to 20 kmh , i never go in mud or climp hill with it before the sound start. It made 3 week now the problem is still there , i removed the belt to place a new one but when i removed it i saw the belt was like a new one ! i still changed it , i reported the problem to can-am they changed the clutch and the problem is still there... ill talk to them this week to see what they will do , a guy who live 3 house next to me just bought one last week he have 100km on it and the belt is not squealing at all !

also forgot the say that first when i changed the belt , the clutch was slipping at +- 80 kmh @ 7500rpm to 8000 ! i made 200km since they changed the clutch and it did not slip since but still making that borring squeal ...

ill repost soon ! , sorry for my bad english im french :p
 

·
Registered
Joined
·
2,964 Posts
So I have 95 miles on my maverick now and haven't really been beating on it but at low Rpms like 3000 when I am in high or low and just creeping the belt is making a squealing or like whining noise. Anyone else have this issue or is my belt junk already? It doesn't seem to slip when I get on it tho? Any input? Thanks
Mine did the same thing. It still does it some after the belt gets hot, but I'm still running my original belt with almost 700 miles. I just had it off again today, and it's still in good shape
 
1 - 15 of 15 Posts
Top