Can-Am Maverick Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
I've noticed after I ride for about 30min to hour and cut my mav off and let it set for a few min then try to start it bk up its takes it a second to turn over. Anybody else havin this problem? No extra add ons for it to do this. At the moment
 

·
Registered
Joined
·
46 Posts
Is your mav one of the early ones? I know some of them had junk starters in the beginning that would leave you stranded. I vaguely remember someone posting pictures of the starters with issues and starters without!
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
It's a 2013 prolly 4 weeks old. The dealer only had it a week b4 I picked it up. So who knows if it's a early 13 or not. Ha.
 

·
Registered
Joined
·
2,964 Posts
Have your dealer run your vin # for recalls. There is a starter recall out. My dealer said they needed to look at the starter to see if it was in the batch for the recall.
 

·
Registered
Joined
·
7,381 Posts
it's the starter….tell your dealer to look up the recalls on your Maverick….
 

·
Registered
Joined
·
36 Posts
So I have also kinda of noticed this problem. It has never not started, but cranking amps seem low when trying to turnover after recently turning off. My dealer said that I did not have the recall, so is this normal? I am changing my clutch out right now so how would I know myself if the starter was bad. Pictures?
 

·
Registered
Joined
·
354 Posts
Mine was doing the same thing more or less.We thought it was the starter too but it was only a loose connection on the positive side of the battery.On mine when there was nothing at the switch,wouldn't turn over,there also wasn't any lights.Tightened up the positive cable and found it to be cross-threaded so it seemed tight but wasn't getting good contact. starter.jpg There's the starters.The one on the right is the china one.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #10
Sox... They don't have a recall out yet to what my deal said but did tell me there fixin try and get it out. They r warranting mine as we speak. Weighting for it to come in
 

·
Registered
Joined
·
46 Posts
Semi Related I guess, but I don't what it is about the dealerships failing to properly tighten battery cables but I've had about 3 buddies with new machines that had mystery ghost electrical problems that would come and go... Turned out to be the battery cables weren't tight! Such a simple thing that you take for granted the dealership did when they uncrated the thing.
 

·
Registered
Joined
·
7,381 Posts
So I have also kinda of noticed this problem. It has never not started, but cranking amps seem low when trying to turnover after recently turning off. My dealer said that I did not have the recall, so is this normal? I am changing my clutch out right now so how would I know myself if the starter was bad. Pictures?
Sox - give me your serial number and I will tell you if the recall applies to you or not.
 

·
Registered
Joined
·
36 Posts
Heavy....everyone was saying that its the last 4 of the vin? mine is 5035. Not sure if it true or not, but getting ready to take it apart and install STM. I will be able to tell once i pull off the console, hopefully its not shiny......
 

·
Registered
Joined
·
7,381 Posts
yours shows up on the list….

serial number.jpg
 

·
Registered
Joined
·
7,381 Posts
Damn! thanks for your help Heavy. where do you get all this info?
Sorry, been at my sons championship football game. They ended the season undefeated and won 37-18! PM me your email address and i can forward you the entire document.
 

·
Registered
Joined
·
36 Posts
PLUM /HEAVY......looked at my starter today and if you look at the picture PLUM sent me showing the (2) different starters, I have the one on the left with the orange sticker "made in thailand". I assume this is the good one. On another note.....the reason i was able to see this is because I am installing RAGE 3. Question 1; Looking at my stock clutch they put all these blue marks from the factory on it, the infamous primary bolt has a an arrow on it pointing to another mark on the clutch. these are still lined up perfectly! I assume they did this to measure if there was slip. did I just waste $1,500 on a RAGE 3?:sad:
 

·
Registered
Joined
·
354 Posts
That's the good one ,Nippondenso.,sp,...You don't need to replace the clutch bolt if you're putting on new clutch,just use the bolt that came with the new clutch.
 
1 - 20 of 21 Posts
Top