Can-Am Maverick Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9,625 Posts
Discussion Starter #1 (Edited)
My front axle decided it did not like my X3 anymore. Broke the CV this weekend in Glamis. Heard a noise and started to smell CV grease shortly afterward.

Time to replace all the axles. 7500+ miles is good enough on the original axles.
 

Attachments

  • Like
Reactions: Username taken

·
Registered
Joined
·
9,625 Posts
Discussion Starter #2
This weekend I got to use my Seal Savers CV boot cover on my friend's X3. He tore his boot and the cover worked awesome. He continued on the rest of the weekend.
 

Attachments

·
Registered
Joined
·
9,625 Posts
Discussion Starter #4

·
Registered
Joined
·
1,323 Posts
Did the boot rip or pop off, or did the CV cup break?
 

·
Registered
Joined
·
9,625 Posts
Discussion Starter #6
Did the boot rip or pop off, or did the CV cup break?
The star broke and shot the ball out. Not sure if the boot ripped at the clamp first or after the CV broke.
 

·
Premium Member
Joined
·
3,290 Posts
I have zero complaints with the factory X3 axles. My rear ones are still going strong currently at 8500 miles. My fronts have probably about 6000 on them after I switched to Smartlok. I did break one shaft in sand hollow last time I was there but it was a summers brother shaft with stock CVs. I put the stock shaft back in and have it as a spare now. The axles had summers bro shafts in when I got them.


Sent from my iPhone using Tapatalk
 
1 - 7 of 7 Posts
Top