Can-Am Maverick Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter #1
As the title states. I blew my belt last weekend, only 230kms on it and literally the day my 10 hour service came up. The belt disintegrated into pieces, the primary clutch has a nice rattle to it, and the secondary doesn't spin true. Is any of this normal?

VoxerMessage_zps7e9366c3.jpg

20140409_200550_zps5481bd56.jpg

 

·
Registered
Joined
·
211 Posts
Mine rattles, too, but not that bad. The rattle completely disappears once you step on the gas and it gets over 2000 rpm.
 

·
Registered
Joined
·
350 Posts
Discussion Starter #4
That is good to know. What about the ever so slight wobble in the secondary? I didn't bother making a video of it because you wouldn't see it without a dial indicator on video. Can be seen with the naked eye though. What about the belt, is that how they normally go? I'm going to try get them to warranty a bucket of pieces without bringing the machine in, or am I wasting my time? It looks like it blew hard enough to break a few small pieces off the cover.
 

·
Registered
Joined
·
211 Posts
Yah, that's what the belt looks like after it blows. As for the damage, I have not had any damage on any of my blown belts on either my Commander or my Maverick. But now that I have said that I'm sure all hell will break loose next time!
 

·
Registered
Joined
·
2,964 Posts
You need to open the secondary and make sure you have all of the belt debris out of it, but no...it shouldn't wobble
 

·
Registered
Joined
·
350 Posts
Discussion Starter #7
Yeah I opened it right up and spent a good hour cleaning up everything I could find. Still need to clean up the clutch surfaces

Sent from my SGH-I747M using Tapatalk
 

·
Registered
Joined
·
4,536 Posts
lube up the 1 way bearing
 
1 - 8 of 8 Posts
Top