Can-Am Maverick Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
I added the charge tube that has the bigger 50mm port and BOV RPM 360 but it was really hard to fit and then it kinks between the chargetube and turbo tube.. did i do it wrong?
But also im not sure if this was the bext move on a stock motor... feels like i lost power..
 

Attachments

·
Registered
2020 XRC Turbo RR
Joined
·
1,400 Posts
Did you check for boost leaks? As for the kink, have someone push on the gas pedal and see if it expands out. These charge tubes swell a little. FWIW, you wouldn't need a 50mm BPV even if you were making 400hp.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #3 ·
Did you check for boost leaks? As for the kink, have someone push on the gas pedal and see if it expands out. These charge tubes swell a little. FWIW, you wouldn't need a 50mm BPV even if you were making 400hp.
yeah i dunno why i did that, dumb move on my part...might just buy another kit if i cant return it... the kink bothers me thou
 

·
Registered
2020 XRC Turbo RR
Joined
·
1,400 Posts
I have RPM charge tubes albeit with a 25mm BOV. If I had to do it over again I'd buy the Evo version. The RPM tubes are fine but the clamps and BOV are super cheap. I have replaced the turbo cold side and TB clamps as well at the BOV. Given that you have a TIAL BOV you probably don't have the Chinesium quality issues of the 25mm units. If I were in your shoes I'd probably loosen all of the clams and try to rotate the tubes to work out the kink (no pun intended). If that doesn't work you may need to trim the ends of the tubs to change the angles they interface with against the IC and TB. RPM has great CS and you may want to give them a call, I lost the boost reference cap and they were quit to send out replacements at no charge.
 
1 - 9 of 9 Posts
Top