Can-Am Maverick Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,777 Posts
Discussion Starter #1
I have been researching gauges for some time and bought a few Intellitronix LED gauges. Ive read a few threads about the oil pressure sending unit location but saw another spot that seems to be also for a sending unit but not sure if its for oil pressure or water temperature. I was curious if any of you members used this location for installing a sending unit. The plug is 10mm x 1 and is on the PTO cover. I am aware of the oil pressure hole on the top of the engine between the heads but that spot sucks for mounting a sending unit. In fact, my sending unit won't fit without stacking adapters which I don't want to do because engine vibration will probably cause a leak or worse damage the fitting and sending unit. I even purchased a nylon tube and fitting kit to allow remote mount of the sending unit. Even that small fitting was tight to the engine. It actually slightly contacts the head of the engine bolt but it seems I can tighten the fitting without damaging the fitting or engine bolt.

Any feedback you can offer would be much appreciated.

other oil plug location.jpg other oil plug location2.jpg IMG_3412.JPG IMG_3420.JPG
 

·
Registered
Joined
·
1,777 Posts
Discussion Starter #3
Second location? You mean on top of the engine in the valley? I know there is another spot above the oil pressure switch on the passenger side as well but don't think my sending unit will install directly without an adapter.
 

·
Registered
Joined
·
2,964 Posts
Dont use brass fittings stacked ont the sending unit that comes with Auto Meter electric gauges is too big and heavy. The brass fittings will break. Dont ask how I know. I changed over to a mechanical gauge and have not had à problem since.
 

·
Registered
Joined
·
7,381 Posts
The PTO cover location worked great. I could install that huge oil pressure sending unit without any adapters.
let me know what you see for pressures hot and cold at idle and at 6K+ RPM's....just want to compare.
 

·
Registered
Joined
·
7,381 Posts
thanks man....
 

·
Registered
Joined
·
7,381 Posts
Thinking I have around 45-50 when cold at idle and hot at idle around 25-30psi.
Same here.....thanks. I see around 60-70psi at RPM both cold and warm.
 

·
Registered
Joined
·
7,381 Posts
I never take it out of sport mode. So yes, that's in sport mode ?
 
1 - 14 of 14 Posts
Top