Can-Am Maverick Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
I tried to send you a private message and got this
"///AIRDAM has exceeded their stored private messages quota and cannot accept further messages until they clear some space."

I recieved the second switch setup and after installing it it displays E and says transmission fault. What do we need to do to fix this.

The first one I got works perfect.

Rick
 

·
Registered
Joined
·
1,072 Posts
Is this for another machine? I do know if you run a light or another accessory to the harness and use it as the ground it will show E trans signal error.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #3
No ,I got two mavericks, everything hooked the same on both. The other works fine. Thanks for the info tho..
 

·
Registered
Joined
·
322 Posts
Not to theadjack but what does this switch actually do...I mean, I know it enables sport mode in low, that's fine, but what is the backend doing...just a relay or how is it performing the action?
 

·
Registered
Joined
·
217 Posts
Did it show,error when u just hooked it up and turned key on ?? I know mine says you cant be moving and flip the switch or it throw the code says to turn maverick off then turn off sport low switch to clear code mines the one from dz idk if it would b the same
 

·
Registered
Joined
·
25 Posts
Good question does it just jumper out something?
 

·
Registered
Joined
·
711 Posts
rick i dunno how my PMs are full i only have 5.

send me a PM with your phone number. its one of two things that could be wrong. there is very little to go wrong with the setup, only two thing that it could be and i have seen both happen, so shoot me a PM i will get you fixed up.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #8 (Edited)
With the key on and not running, in high and in sport mode its all good, go to low gear non sport it is fine. As soon as you hit the switch the E comes on and the transmission fault scrolls across the display and after 30 seconds maybe less the chk engine light comes on.

If it is running the exact same thing happens and it feels like the sport mode power untill the chk engine light comes on and it go in limp mode, however its such a short time its really hard to tell if its in sport mode.

I think its just the wrong resister or a bad one not sure.

I type slow. I sent you my number
 

·
Registered
Joined
·
96 Posts
Discussion Starter #9
Not to theadjack but what does this switch actually do...I mean, I know it enables sport mode in low, that's fine, but what is the backend doing...just a relay or how is it performing the action?
Each gear postion has a resister that changes the voltage to tell it what postion the shifter is in, you are tricking the computer to have full power when in low range, computer shows its in high gear and lets it have 100% power when its in low range.
 

·
Registered
Joined
·
761 Posts
Made a relay that works in low sport, and I ran it so when you put the sport mode swich in the on position it works in low and high. I didnt want to add another switch to my dash. So I just ran the relay threw the stock sport switch. It makes for a clean install.
 

·
Registered
Joined
·
35 Posts
01 can you describe in more detail what you did, parts, where you spliced it into, etc.

Thanks

Not having another switch sounds great to me

Made a relay that works in low sport, and I ran it so when you put the sport mode swich in the on position it works in low and high. I didnt want to add another switch to my dash. So I just ran the relay threw the stock sport switch. It makes for a clean install.
 

·
Registered
Joined
·
711 Posts
its likely a bad switch.

when rick builds these kits, he has a machine that tests them and runs power and a load thru them. the only thing he does not check is the actual dash switch. we always "assume" the dash switch is going to work out of the box. we have had two now that had a bad switch.
 

·
Registered
Joined
·
329 Posts
Does anyone know or have a opinion why Can Am does not let the sport setting work in low. Why would they not want you to have full power in low?
 

·
Registered
Joined
·
59 Posts
Maybe someone can do a better drawing on the computer. I always just come up with this shet in my head...
Works great, pulls front wheels about 2" off the ground on pavement.....


Damn! I like this set up much better than having a seperate switch to switch when I want to engage sport low. I made my own harness for sport low with some resistors from Radio Shack. I will be copying this when I get a little more time to make up a relay switched harness. Super-cool!!
 

·
Registered
Joined
·
1,255 Posts
I bought the on from articbomb and it works great, hooked it up last night and took a few short burst. Does have some grunt now in low. What really sucks is all the push/pull pins just to work on the damn thing. Plug and play by the way.
 

·
Registered
Joined
·
59 Posts
This evening I made up my own harness using 01Cummins drawing. Relay with pigtail( $6.99 at O'Reilly's), 2 resistors from Radio Shack (less than $2) and a pair of 2 pin connectors from Radio Shack ($5). Now I have one switch, the factory switch for Sport mode. When I am in low, I flip the Sport switch and the indicator shows High range and Sport mode activated. 01Cummins, I can't thank you enough for the input of using a relay instead of a seperate switch. Works like factory and all my buddies now think I'm an electrical genius! Now I'm finally done installing accessories and mods and I can go really drive this thing!
 
1 - 20 of 23 Posts
Top