Can-Am Maverick Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
Before I haul my 2014 Maverick XRS up to the dealer I wanted to see if anyone had a suggestion.

When I flip the 4x4 switch nothing is happening. I tried it in all gears, from a dead stop and slow speeds, and I removed the switch panel and checke to see that the switch is plugged in and right. It has worked before but this is the first time I needed it on a trail ride.

Nothing lights up on the dash display and the fronts are definately not spinning.

Since the dash indicator isn't lighting up I am assumjng the actual switch on the dash might be faulty but at this point it's a guess.

Any ideas?
Brandon
 

·
Registered
Joined
·
1,103 Posts
Check fuses...other than that.. if power source is good
..either a switch or actuator...??

Sent from my SCH-I545 using Tapatalk
 

·
Registered
Joined
·
725 Posts
Mine did the same thing and the fuse looked good, I went ahead and changed the fuse and now it works flawlessly!!
 

·
Registered
Joined
·
127 Posts
Discussion Starter #4
RiverRat, which fuse was it? The fuse box cover diagram does not specify that one of the fuses is fir that specific switch or front diff actuation.
 

·
Registered
Joined
·
4,536 Posts
people say water gets in from cig plug charger make sure that stays shut when washing , fuse is under driver side dash pop cover off and check ,, spare fuses in there, super easy take flashlight with u

cig plug fuse
 

·
Registered
Joined
·
725 Posts
Killrb u can peel that top layer off of fuse sticker so that u can read easier, I don't remember off hand which one it is, I believe it's a 5amp fuse
 

·
Registered
Joined
·
7,381 Posts
Here is the fuse/relay descriptions....

071.jpg
 
1 - 9 of 9 Posts
Top