Can-Am Maverick Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
When I push my button on nothin comes on my screen sayin 4wd my switch does not light. Not of my switches light up period. What's goin on?
 

·
Registered
Joined
·
7,381 Posts
I replied to your other thread….Check fuse F7 it is a 5A fuse for the switch illumination, the 2wd/4wd, and winch switch……

Power Distribution.jpg
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
Appreciate it. Now this bike is a day old where will my fuse box b I know there is 2 boxes but my manual just says under drivers feet
 

·
Registered
Joined
·
7,381 Posts
Its under the drivers side dash on the left hand side tucked up under there….It should have a white label on it showing you what each fuse/relay is on the inside….
 

·
Registered
Joined
·
7,381 Posts
no problem….let us know if that was the problem...
 

·
Registered
Joined
·
7,381 Posts
Awesome…glad to help out.
 

·
Registered
Joined
·
4,536 Posts
what would make the fuse pop tho in the 1st place?
 

·
Registered
Joined
·
7,381 Posts
my guess would be getting water in the 12vdc accessory plug on the dash and shorting it out will blow the fuse...
 

·
Registered
Joined
·
4,536 Posts
my guess would be getting water in the 12vdc accessory plug on the dash and shorting it out will blow the fuse...
Ah ok. Makes sense ! Thx
 

·
Registered
Joined
·
7,381 Posts
Ah ok. Makes sense ! Thx
yea...make sure you have the rubber cap secured when you wash it or there is a good chance this will happen.
 

·
Registered
Joined
·
4,536 Posts
ok cool
 
1 - 15 of 15 Posts
Top