Can-Am Maverick Forum banner

21 - 30 of 30 Posts

·
Registered
Joined
·
1,918 Posts

·
Registered
2018 Maverick X3 Max X rs Turbo R
Joined
·
40 Posts
What condition are your belt and clutches in? I'm wondering if you're experiencing belt slippage or something going on with your clutches...
 

·
Registered
Joined
·
1 Posts
Hey Everyone,

Did some riding this weekend and had an issue where when taking off from a stop (high, low and reverse) my machine will just lose throttle response entirely and just stall somewhat. I can press the pedal to the floor and nothing happens. I don’t lose power(electrical) or anything it just kind of stops. If I let out on the gas pedal and press again it goes on just fine. It doesn’t do this every time and just at complete random.

Throttle sensor of some sort maybe? Im not sure lol. It doesn’t sputter or shake or anything just acts like I let off the gas. nothing shows up on the dash and I don’t think (will try and see again to be sure when I get a chance) the rpms drop or anything either.

Anyone ever ran into this by chance?

Thank you!
Mine did the same thing. Do you have XTC turn signal kit installed?
 

·
Registered
18 Mav T
Joined
·
12 Posts
I get the yet, but if like GM and the C8 Corvette, they have not and WILL not crack it. The workaround is a chip replacement or standalone ECU. The C8's encryption is 2048 kb. Todays manufactures are calling their software proprietary and you don't own it.
Welcome to the future.
Buy an older unit !
 

·
Registered
Maverick X3 XDS
Joined
·
25 Posts
Hey Everyone,

Did some riding this weekend and had an issue where when taking off from a stop (high, low and reverse) my machine will just lose throttle response entirely and just stall somewhat. I can press the pedal to the floor and nothing happens. I don’t lose power(electrical) or anything it just kind of stops. If I let out on the gas pedal and press again it goes on just fine. It doesn’t do this every time and just at complete random.

Throttle sensor of some sort maybe? Im not sure lol. It doesn’t sputter or shake or anything just acts like I let off the gas. nothing shows up on the dash and I don’t think (will try and see again to be sure when I get a chance) the rpms drop or anything either.

Anyone ever ran into this by chance?

Thank you!
Was having the same problem. I have a 2019 DS. I changed my belt seemed to fix the problem the belt had small nicks on that not too bad but it seem to fix the problem so far
 

·
Registered
2021 Can-Am Maverick X3 XRS Turbo-RR w/ Smart-Shox
Joined
·
1 Posts
Hey Everyone,

Did some riding this weekend and had an issue where when taking off from a stop (high, low and reverse) my machine will just lose throttle response entirely and just stall somewhat. I can press the pedal to the floor and nothing happens. I don’t lose power(electrical) or anything it just kind of stops. If I let out on the gas pedal and press again it goes on just fine. It doesn’t do this every time and just at complete random.

Throttle sensor of some sort maybe? Im not sure lol. It doesn’t sputter or shake or anything just acts like I let off the gas. nothing shows up on the dash and I don’t think (will try and see again to be sure when I get a chance) the rpms drop or anything either.

Anyone ever ran into this by chance?

Thank you!
Don't panic..
My 2021 XRS SmartShox does the same thing.
I don't know what causes it but I just assumed it was a anti-destruct feature.
 
21 - 30 of 30 Posts
Top