Can-Am Maverick Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Has anyone experienced a dead throttle pedal or a very laggy pedal when crawling in low or coming of an incline and you go to give some throttle and it does not react tell you almost full throttle
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #11 ·
I have only noticed it in low and it’s done it on any terrain incline flat and climbing and it not all the time. I would think it might have something to do with throttle position sensor or something similar
 

·
Registered
Joined
·
3 Posts
I have a 2021 X3 RR RC and have the exact problem you have described. 120 miles, changed belt same issue, bought new throttle pedal same issue.
Did the Rubicon trail lost throttle response at least 50 times (downhill, uphill, after brake, throttle, brake) even happened in reverse on flat terrain.
happens in sport mode, eco mode, trail or rock mode, 4x4 and 2x4, high or low range or any combination. Steep incline, crawl up, apply brake, apply throttle while letting off brake (nothing-hold throttle to floor for 5-7 seconds and throttle comes on -OR- let off throttle and reapply then will work. checked all connections and could not find anything loose or pinched.

Too intermittent to do any more extreme rock crawling as this could really get you into trouble if the throttle does not work when you need it to.
Going to dealer on Tuesday. they are also at a loss as what this could be.
 

·
Registered
Joined
·
880 Posts
Applying brake and gas at the same time?? I believe there are some nannies on the newer units that kick in and kill the ability to throttle, if applying brakes at the same time.

May not be your issue,,, but I believe I've read something like that around here.
 

·
Registered
Joined
·
3 Posts
Applying brake and gas at the same time?? I believe there are some nannies on the newer units that kick in and kill the ability to throttle, if applying brakes at the same time.

May not be your issue,,, but I believe I've read something like that around here.
Just took the car out again to determine if that was a factor. It seems to do it when you’re in extreme crawl situation where there’s a lot of stopping and starting. Crawled out of a group of rocks and dead peddle.
All the way to floor, nothing, actually had to lift off the pedal completely reapply before it would actually work.
Apply and break and gas was not the issue in this situation as I crawled out of the rocks with no break just slow acceleration settled at the top, push the accelerator pedal and nothing.
 

·
Registered
Joined
·
2,212 Posts
your car needs to be reprogrammed...
there is new firmware for the 21s
but you can always use the override button
when you get the gear warning/error
 

·
Registered
Joined
·
2,212 Posts
the puke orange dash makes it hard to see warnings
 

·
Registered
Joined
·
1 Posts
Has anyone experienced a dead throttle pedal or a very laggy pedal when crawling in low or coming of an incline and you go to give some throttle and it does not react tell you almost full throttle
Just curious if you ever came up with a solution to this problem? I have a 2021 X3 XRS RR with exact same thing of which I discovered while climbing in Moab! Not a fun feeling!
 

·
Premium Member
2020 X3 X RS RR
Joined
·
596 Posts
Just curious if you ever came up with a solution to this problem? I have a 2021 X3 XRS RR with exact same thing of which I discovered while climbing in Moab! Not a fun feeling!
It's torque management not allowing throttle when the RPM are 2500 or so when on the brake pedal. You can either get a tune that removes that or the Evo bypass switch they use on their launch control. Just watch it as you can smoke a belt much easier.
 
1 - 19 of 19 Posts
Top