Can-Am Maverick Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Just bought 2017 maverick ds turbo-took it out this weekend -less than 60 miles started over heating! Fan works help
 

·
Premium Member
Joined
·
12,142 Posts
Welcome from Tucson AZ. X3 DS? Which key did you have in? Hopefully it was the performance one? Possibility of an air bubble in the system? Just bring it back to the dealer, and let them fix it. 60 miles, it shouldn't be overheating.
 

·
Registered
Joined
·
3,590 Posts
Welcome from Nova Scotia Canada....What Hollywood said that's not normal take it back to the dealer.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
Yes, performance key was in use. Ran great all day then on last ride engine overheated and went into limp mode. Checked fluids and fan fuses -everything looked good
 

·
Premium Member
Joined
·
12,142 Posts
Any possibility that the radiator was clogged with mud / dirt?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
Pardon my ignorance, this is my first utv. Do they have thermostats in them? If so, could it be stuck? Where is it located?
 

·
Registered
Joined
·
969 Posts
If you just bought it, shouldn’t you take it in and get it fixed? Should be under warranty correct?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #10 ·
Yes, bought it new and plan to take it to dealer- just didn't want to wait several weeks to get it into the dealer if it's a simple fix.
 

·
Premium Member
Joined
·
7,813 Posts
Yes, bought it new and plan to take it to dealer- just didn't want to wait several weeks to get it into the dealer if it's a simple fix.

Sorry to hear about the overheating issue.

the older Model had to be burped to get all the air out, whether that applies here we dont know.

This motor is relatively new to to us so we don't have the knowledge base like we did on the last gen.

Please take the time to come back and post what it was so we can build the knowledge base on this series.

Tim
 
1 - 11 of 11 Posts
Top