Can-Am Maverick Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Hello guys,

I have an issue with my 2014 Can-Am Maverick XRS DPS.
The machine makes a horrible squealing, popping, ratcheting noise when I make right turns and while backing up.
I have done a lot of work to my machine. I have also double, triple, and quadruple checked\verified specs and proper seating.
First, I have searched the net, and trouble shot everything from shock, brakes, cv jonts, cvt clutches, and more.
At this point, I am at my wits end. Trying not to go to the dealership without having some idea of what is causing the issues.

Technical Info:
All items below have less than 10 hours of ride time:
  • Primary and Secondary clutches cleaned\serviced
  • Dalton Clutch kit setup up for 30"+ tires\wheel
  • UATV Tech primary clutch lock-up mod
  • One-Way has new sealed bearings and serviced with Isonoflex grease
  • CVT primary low engagement spring
  • New Gates CVT belt (break in procedure followed)
  • Front diff, gear box, rear diff fluid change
  • Oil and filter change
  • Chassis and drive shafts greased
  • AREED shocks with new spherical bearings and new o-rings (greased and lubed)
  • New OEM bearings on all 4 corners (greased)
  • New OEM front upper and lower ball joints
  • All bushings replaced Super Dave bushings (greased)
  • Super ATV 3" lift kit (total 17" of clearance)
  • Turner II upgraded axles (confirmed fully seated and break-in procedure followed)
  • 14" STI HD wheels with 30x10x14 EFX Motoclaws
  • New Race Driven brakes on all 4 corners (moving components and pins greased)


Important notes:
The squealing and ratcheting noise appears to be coming from the right side. Sometimes I think it is the RF wheel and others I think it is the RR wheel.
The squealing and popping is intermittent.
The machine was running well, then seamed to start having noise issues, after a run through some mud.
For clarity, the trouble shooting steps were done, after the mud run.

Trouble shooting:

  • Lifted the Mav (all 4 wheels) and cannot duplicate the issue
While the Mav was lifted, I ran it in 2wd, 4wd, H, L, and Reverse gears. I also turned the steering wheel to the right and left.

  • Greased the shocks, brakes, chassis, and drive shaft
  • Verified CVT clutches are not wobbling or out of alignment
  • Verified CVT belt is not glazed
  • Dis-assembled hubs and axles to assure proper installation (used shop manual to confirm specs)
  • Confirmed all (4) axles are torqued to spec
I have not taken the boot off of the the axle CV joints, but I have done manual turning and cannot duplicate the squealing and popping noise
Any help, direction, or insight would be appreciated.
I have included video clips to better explain the issue that I am having.
There is a video of the right turn and a video of the backing up..


Thanks in advance..
 

·
Premium Member
Joined
·
11,576 Posts
Popping is usually a dead give away your CV's are shot on the diff end. Or diff bearings are going, and transferring it to the CV's. I'm willing to bet it's one of those two.
 
1 - 3 of 3 Posts
Top