Can-Am Maverick Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter #1
i'm at almost 13 hrs , and no service eng light? i serviced it at 9.7 hrs. Can't see how the ecu would know it was serviced, so what is the longest you guy;s have went? Does mileage play any part ?
 

·
Registered
Joined
·
1,298 Posts
if you serviced it at 9 your good. there is a way to reset the engine service light in your manual. did you do the service yourself? if dealer or someone else done it they likely reset it
 

·
Registered
Joined
·
168 Posts
I had 23 hours on mine before the stealership was able to schedule me in. I never did get a service engine light.
 

·
Registered
Joined
·
145 Posts
I did my first service at 7 hrs and 160 miles. I was hammering back roads and fast trails, so I wanted to get it changed not wait for the hr meter.
 

·
Registered
Joined
·
177 Posts
Discussion Starter #6
i did my own service. I just don't trust the stealership . wondering if they could have run it and reset the ecu. didn't have miles on it, but when i was there they were bragging about how well a quad ran that they took out that weekend, they were washing it and pushing it back on the showroom floor when i was doing paperwork. my tires also had slices in them like they were run. Didn't notice until i got home.
 

·
Registered
Joined
·
145 Posts
I did my own service at 160 miles and 7 hrs as stated above. I now have 231 miles and 11.9 hrs, no service light. The dealer has not seen my Mav since it rolled out of their driveway. So when will it pop on?
 

·
Registered
Joined
·
548 Posts
My light came on at exactly 10.0 hours. Did the service (all but the valve adjustment)at 11.5 and reset it. I am up to 21 now, and will be doing the valve adjustment this weekend. I saw so many posts of the valve clearence not opening up at 10 hours, I figured I'd wait. I still don't hear any valve noise in it, but I'm thinking I have held off long enough.
 

·
Registered
Joined
·
7,381 Posts
The service indicator message pops up on startup. It isn't a CEL light that stays illuminated all the time. So start the engine and watch the messages that scroll across the screen....
 

·
Registered
Joined
·
145 Posts
I did that Heavysledz and didnt see it. On my Renegade it did it on start up and every once in awhile while riding. I will check it again on start up next time I at my Mav.
 
1 - 11 of 11 Posts
Top