Update: Unresolved issues since new with 18.5 RS Turbo R P0301, P0302, P0303 - Page 10
Can-Am Maverick Forum - Powered by vBulletin

Update: Unresolved issues since new with 18.5 RS Turbo R P0301, P0302, P0303

This is a discussion on Update: Unresolved issues since new with 18.5 RS Turbo R P0301, P0302, P0303 within the Maverick Discussions forums, part of the Can-Am Maverick Forums category; I posted that PM'd Vanessa with a link to this thread over a week ago and still no reply....

Page 10 of 16 FirstFirst ... 89101112 ... LastLast
Results 91 to 100 of 157
Like Tree170Likes

Thread: Update: Unresolved issues since new with 18.5 RS Turbo R P0301, P0302, P0303

  1. #91
    Senior Member HPnMORE4J's Avatar
    Join Date
    Jun 2018
    Location
    Oregon
    Posts
    853
    Member #
    48432
    Liked
    297 times
    I posted that PM'd Vanessa with a link to this thread over a week ago and still no reply.
    AZSteele likes this.

  2. #92
    Supporting Member
    Premium Member
    Desertdog01's Avatar
    Join Date
    Aug 2018
    Location
    Some where in Santa barbara ca.
    Posts
    1,748
    Member #
    49290
    Liked
    991 times
    Did you get this from private party or used from a dealer , how many miles when you got it
    Life doesent get much better than eating taco’s down at scorpian bay ,baja sur
    2018 x3 xrs/ smart lok,rugged radios,baga design squadron pro’s,onyx6,afx alum. Lower doors,brp door handles, Evo c/d + tune, wet sounds elite 10, aim belt temp, + way too much to list need more $$ not close to being done

  3. #93
    Senior Member HPnMORE4J's Avatar
    Join Date
    Jun 2018
    Location
    Oregon
    Posts
    853
    Member #
    48432
    Liked
    297 times
    Quote Originally Posted by Desertdog01 View Post
    Did you get this from private party or used from a dealer , how many miles when you got it
    The details are in a previous thread.
    I took possession with around 100 miles on it, under factory warranty and an additional extended warranty for 4.5 years after the 6 month period.

  4. Remove Advertisements
    MaverickForums.net
    Advertisements
     

  5. #94
    Supporting Member
    Premium Member
    Desertdog01's Avatar
    Join Date
    Aug 2018
    Location
    Some where in Santa barbara ca.
    Posts
    1,748
    Member #
    49290
    Liked
    991 times
    If you bought it used from a private party , its a lot different than if you bought it new from a dealer, so your saying you bought it with a100 miles on it and its been having trouble since you bought it , ? If the previous owner had troubles or if he sank it or something, If you bought it used from a dealer the dealer should make it right and give you another car ,
    things get sticky when problems arise on a used vehicle in ca once its been registered even if it has zero miles its considered a used vehicle once again best wishes for you in getting a resolution
    Life doesent get much better than eating taco’s down at scorpian bay ,baja sur
    2018 x3 xrs/ smart lok,rugged radios,baga design squadron pro’s,onyx6,afx alum. Lower doors,brp door handles, Evo c/d + tune, wet sounds elite 10, aim belt temp, + way too much to list need more $$ not close to being done

  6. #95
    Senior Member Odyknuck's Avatar
    Join Date
    Sep 2012
    Location
    Chardon, Ohio area
    Posts
    1,200
    Member #
    238
    Liked
    406 times
    Quote Originally Posted by HPnMORE4J View Post
    The details are in a previous thread.
    I took possession with around 100 miles on it, under factory warranty and an additional extended warranty for 4.5 years after the 6 month period.
    Hmmm! It sounds to me like the previous owner of the X3 had the issues and traded in in on a new one and you got stuck with his problem.

  7. #96
    Senior Member HPnMORE4J's Avatar
    Join Date
    Jun 2018
    Location
    Oregon
    Posts
    853
    Member #
    48432
    Liked
    297 times
    Please let's not get into assumptions....

    There was ZERO damage to the vehicle at 100 miles.

    It was under full factory warranty in my name and extended warranty in my name and they cannot find the issue after 9 weeks in service, 12 weeks now without resolve which is the issue.
    Hollywood X3 likes this.

  8. #97
    Supporting Member
    Premium Member
    Desertdog01's Avatar
    Join Date
    Aug 2018
    Location
    Some where in Santa barbara ca.
    Posts
    1,748
    Member #
    49290
    Liked
    991 times
    Not getting into assumptions just saying buying a used vehicle is usually buyer beware , and even though it still had factory warranty ,you don't, get the same protections as you would have if you bought new from a dealer, if the dealer sold you a used car with known problems then the dealer is who you need to deal with not brp. , the dealer should find you another 18.5 low milage car then switch out your acc. and send this car to brp to take apart and figure out what the trouble is
    Life doesent get much better than eating taco’s down at scorpian bay ,baja sur
    2018 x3 xrs/ smart lok,rugged radios,baga design squadron pro’s,onyx6,afx alum. Lower doors,brp door handles, Evo c/d + tune, wet sounds elite 10, aim belt temp, + way too much to list need more $$ not close to being done

  9. #98
    Supporting Member
    Premium Member
    Desertdog01's Avatar
    Join Date
    Aug 2018
    Location
    Some where in Santa barbara ca.
    Posts
    1,748
    Member #
    49290
    Liked
    991 times
    Maybe talk to the dealer and see if he will let U use a data logger to try and see whats going on before and during your misfires If everything has been replaced as they tell you there’s no reason for any of this to be happening it should be like a new car Its beyond frustrating for you, but its driving us nuts wondering why this is happening! not trying to be jerk or anything Im just thinking out loud
    Life doesent get much better than eating taco’s down at scorpian bay ,baja sur
    2018 x3 xrs/ smart lok,rugged radios,baga design squadron pro’s,onyx6,afx alum. Lower doors,brp door handles, Evo c/d + tune, wet sounds elite 10, aim belt temp, + way too much to list need more $$ not close to being done

  10. #99
    Junior Member Tommyknocker's Avatar
    Join Date
    Aug 2019
    Posts
    6
    Member #
    53353
    Liked
    7 times
    Quote Originally Posted by HPnMORE4J View Post
    Quote Originally Posted by Tommyknocker View Post
    1. You never said why the MAP sensor was changed. If there wasn't the MAPs fault code why did they change it?

    2. There must be some other fault codes along with the P030n ones. Are you sure there is none?

    3. Are you sure the other sensors were replaced. In particular the cranckshaft and camshaft position sensors? Do you have it (the replacement fact) documented on paper? Check again. Make sure they were replaced.

    4. What about the O2 sensor? What is its fate? Replaced? Are you Sure?

    5. Would be usefull to test-replace the catalytic converter pipe and see if there is a change.

    6. Would be usefull to check the valves clearances.

    7. You said compression was measured. Please, provide the values across the cylinders.

    8. Any abnormal engine oil consumption?
    I started to answer your additional questions, most of which has been done and results covered in previous threads.
    At this point it's moot.
    This started within the first 100 miles, and with an expensive extended warranty still in place. I've put way to much time, money, efforts and many missed opportunities, loss and deprecation to date on a machine with almost $40K invested.
    9 weeks in service and now going on 12 weeks without a cure, Can Am techs with no more answers. It's time for BRP/Dealer resolve.

    I do thank you for your help.
    BTW welcome to the forum!
    Quote Originally Posted by Desertdog01 View Post
    Maybe talk to the dealer and see if he will let U use a data logger to try and see whats going on before and during your misfires If everything has been replaced as they tell you there’s no reason for any of this to be happening it should be like a new car Its beyond frustrating for you, but its driving us nuts wondering why this is happening! not trying to be jerk or anything Im just thinking out loud
    Exactly. I am afraid i'll be looking like a jerk in the next one...

  11. #100
    Junior Member Tommyknocker's Avatar
    Join Date
    Aug 2019
    Posts
    6
    Member #
    53353
    Liked
    7 times
    Quote Originally Posted by HPnMORE4J View Post
    Quote Originally Posted by Tommyknocker View Post
    1. You never said why the MAP sensor was changed. If there wasn't the MAPs fault code why did they change it?

    2. There must be some other fault codes along with the P030n ones. Are you sure there is none?

    3. Are you sure the other sensors were replaced. In particular the cranckshaft and camshaft position sensors? Do you have it (the replacement fact) documented on paper? Check again. Make sure they were replaced.

    4. What about the O2 sensor? What is its fate? Replaced? Are you Sure?

    5. Would be usefull to test-replace the catalytic converter pipe and see if there is a change.

    6. Would be usefull to check the valves clearances.

    7. You said compression was measured. Please, provide the values across the cylinders.

    8. Any abnormal engine oil consumption?
    I started to answer your additional questions, most of which has been done and results covered in previous threads.
    At this point it's moot.
    This started within the first 100 miles, and with an expensive extended warranty still in place. I've put way to much time, money, efforts and many missed opportunities, loss and deprecation to date on a machine with almost $40K invested.
    9 weeks in service and now going on 12 weeks without a cure, Can Am techs with no more answers. It's time for BRP/Dealer resolve.

    I do thank you for your help.
    BTW welcome to the forum!
    Well, thank you.

    I've been on this forum for some time, let's call it, in a passive mode, just reading some posts that I was interested in, mostly technical, never even registering.
    But, you know, at some point it seemed your threads started to dominate the entire atmosphere of this platform. So, reading/listening your story over and over again, like an old stuck vinyl, I just reached (you made me actually) the condition of signing up and saying something.
    But quickly I discovered another puzzling thing: you just don't listen to any advises/advisers here. You keep counting days and weeks your long-suffering machine is in the repair shop or somewhere else but I see no real technical effort from you to try to immerse in this by yourself. To try to understand what the *uk is going on with your cart.

    Really, every Saturday once I have time I go to my garage and walk around my xrc thinking what i would do had i got in something like this. I even devised a sequence of actions that I would take ... myself, even before calling anyone or posting anything.

    So, then I asked you several specific, concrete questions, but again, you either answered them superficially, without real technical details, redirected to some old thread or simply ignored, instead playing your vinyl once again and counting weeks. Soon we'll be counting months...

    I totally agree with the author above who just said that after an overhaul this big and amount of replacement made, according to you though, that car should be capable of running from coast to coast and back without a single fart.

    Sometimes i event want to see what kind of creature your car is. Really, if I was within reasonable distance from you, I would just take my maptuner and drive to you to do some diagnostics, at least. Only because you count weeks for us but do not provide real specifics, real technical data.

    As for any real legal dispute with BRP i suggest you just forget about it. Your car is a used one, your BRP warranty expired long ago, the extension that you have is from a third party and it covers what?

    It looks like this situation now can be characterized as something like this: saving someone from drowning is on the one who's drowning ...

    I'm afraid that's it...

Page 10 of 16 FirstFirst ... 89101112 ... LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. The P0302 Code that will not go away.......
    By brnschr1000r in forum Maverick R
    Replies: 13
    Last Post: 09-05-2019, 09:42 AM
  2. Replies: 108
    Last Post: 08-26-2019, 09:47 AM
  3. The best thing since sliced Bread, belt tool for the X3
    By Megadesertdiesel in forum Maverick X3
    Replies: 18
    Last Post: 05-10-2019, 10:52 PM
  4. Random P0301 code
    By superdean in forum Maverick X3
    Replies: 64
    Last Post: 02-20-2018, 01:35 PM
  5. Replies: 20
    Last Post: 06-25-2013, 02:15 PM

Search tags for this page

can am maverick x3 error code p0301

Click on a term to search for related topics.