Transmission signal fault
Can-Am Maverick Forum - Powered by vBulletin

Transmission signal fault

This is a discussion on Transmission signal fault within the Maverick XXC forums, part of the Can-Am Maverick Forums category; Have a 2016 maverick x xc with low and high gears. Also have the sport and eco mode. Has 60 hours on motor. Parked it ...

Results 1 to 2 of 2
  1. #1
    Junior Member Sethcalm's Avatar
    Join Date
    May 2019
    Posts
    1
    Member #
    52285

    Transmission signal fault

    Have a 2016 maverick x xc with low and high gears. Also have the sport and eco mode. Has 60 hours on motor. Parked it somewhere where and 10 min later tried moving it somewhere else and won’t start being it says transmission signal fault. Took off the angle rotation sensor and it was full of grime and water. Someone told me it was the wiring harness. Need help!! What could it be? Should I just replace the sensor or should I pay the money for it to be diagnosed?

  2. #2
    Senior Member Ruger's Avatar
    Join Date
    Apr 2016
    Location
    Grand Junction CO
    Posts
    146
    Member #
    12153
    Liked
    29 times
    Replace the sensor after you have checked wiring around eng and trans, probably be able to bypass the dealer.
    2015 XDS Turbo

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Transmission signal fault
    By Travers in forum Maverick R Max
    Replies: 4
    Last Post: 12-29-2017, 09:38 AM
  2. Transmission signal fault ??
    By Nev in forum Maverick 15-16 XDS/XRS Non-Turbo
    Replies: 0
    Last Post: 05-23-2016, 03:03 PM
  3. Transmission sensor fault
    By jeffoutty800 in forum Maverick 15-16 XDS/XRS Non-Turbo
    Replies: 7
    Last Post: 12-29-2015, 06:06 PM
  4. Transmission Signal Fault, P2801, P0790
    By JP HIS in forum Audio, Lighting and Electrical
    Replies: 5
    Last Post: 08-03-2015, 09:18 AM
  5. Transmission signal fault
    By 2007abc in forum Engine and Drivetrain
    Replies: 1
    Last Post: 04-12-2015, 06:22 PM