Rattling/rolling/box of rocks sound when moving at slow speeds - Page 3
Can-Am Maverick Forum - Powered by vBulletin

Rattling/rolling/box of rocks sound when moving at slow speeds

This is a discussion on Rattling/rolling/box of rocks sound when moving at slow speeds within the Maverick XRC forums, part of the Can-Am Maverick Forums category; Yikes...I have 1850 miles on mine and no issues (yet?) with the carrier bearing the r drive line. Looks to be a pita to do ...

Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29
Like Tree1Likes

Thread: Rattling/rolling/box of rocks sound when moving at slow speeds

  1. #21
    Senior Member gtsum2's Avatar
    Join Date
    Oct 2014
    Location
    Virginia
    Posts
    1,001
    Member #
    3933
    Liked
    246 times
    Yikes...I have 1850 miles on mine and no issues (yet?) with the carrier bearing the r drive line. Looks to be a pita to do though


    2018 X3 XDS

    Sent from my iPhone using Tapatalk Pro
    2018 X3 XDS

  2. #22
    Junior Member mgcardoc's Avatar
    Join Date
    Jan 2018
    Location
    Arizona
    Posts
    23
    Member #
    40194
    Liked
    12 times
    I was discussing this on the trail this weekend and it was brought up that sometimes the aftermarket solid mounted bearings like the one I installed will cause a driveline vibration. The stock one (just like pick up trucks) has the rubber cushion all the way around it to allow a little movement. So far so good on mine, but I can see where that might be an issue.

  3. #23
    Junior Member rocker's Avatar
    Join Date
    Jun 2019
    Posts
    2
    Member #
    52891
    another data point: the day after first big ride out in my new 19 X RS turbo R, mine was making the rattling noises coming from the middle of the car at low speeds. noise could be modulated by running 4WD vs 2WD, and the big ride included several crossings of ~15" water. pulled off the front DS, greased the splines, reassembled, noise is gone. the job was pretty easy.

    i did notice that the OEM carrier bearing's rubber was a lot softer than i'd have expected, but with the greased splines, there is now no noise, so i currently have no reason to change it.

  4. Remove Advertisements
    MaverickForums.net
    Advertisements
     

  5. #24
    Supporting Member
    Premium Member
    Sandman_73's Avatar
    Join Date
    Aug 2016
    Location
    Folsom, CA
    Posts
    2,643
    Member #
    15266
    Liked
    1385 times
    Mine only does it in 2WD. Greasing the splines has always eliminated the noise but this last time it has come back within 100mi or so. Getting a bit old...
    X3 XDS.

  6. #25
    Junior Member rocker's Avatar
    Join Date
    Jun 2019
    Posts
    2
    Member #
    52891
    agreed regarding 2WD; before i greased the splines, mine only made the noise in 2WD and it only fully went away in 4WD + locker.

    i'll report back if the noise comes back on mine. quite possible it's a tolerance issue and the splines could've been cut more precisely.

  7. #26
    Junior Member mrclark's Avatar
    Join Date
    Aug 2018
    Posts
    7
    Member #
    49166
    mine sounds like it's getting worse. it sounds like I'm driving over plates of glass or pieces of dried pasta up until around 3000rpm. I took a look at the carrier bearing and didnt notice any unusual play. To grease the spline do I have to remove the skid plate, then the axle then grease the area contained in the carrier bearing?

    I also have this horrible squeak which sounds like finger nails on a chalk board up and down. I'm tossed between, it being the exhaust or something in the dash. Unfortunately I'm partially deaf in one ear so my directional hearing is gone.

  8. #27
    Junior Member mgcardoc's Avatar
    Join Date
    Jan 2018
    Location
    Arizona
    Posts
    23
    Member #
    40194
    Liked
    12 times
    Quote Originally Posted by mrclark View Post
    mine sounds like it's getting worse. it sounds like I'm driving over plates of glass or pieces of dried pasta up until around 3000rpm. I took a look at the carrier bearing and didnt notice any unusual play. To grease the spline do I have to remove the skid plate, then the axle then grease the area contained in the carrier bearing?

    I also have this horrible squeak which sounds like finger nails on a chalk board up and down. I'm tossed between, it being the exhaust or something in the dash. Unfortunately I'm partially deaf in one ear so my directional hearing is gone.

    No, you don't have to remove the skid plate. Come in from the top. Remove the console so you gain access by the shifter. Then remove the clamp where the front driveshaft bolts to the front differential. Then you can unbolt the carrier bearing (mid ship) and pull the whole driveline off the rear splines. At that point you can split the driveshaft, clean and lube all the splines and reassemble. Or, like I did, you can choose to replace the carrier while you're in there. But I'd probably clean and lube it up first and see if that takes care of your problem. As far as the squeak, is a rolling squeak? Does it stop if you apply the brakes? Can you hear it if you are rolling and the engine is off? I'd find a slight hill, kill the engine and roll down it. See if you still hear it. Then you'll know if its in the running gear/drivetrain/brakes or something in the motor/trans. Good luck!

  9. #28
    Senior Member RBRK's Avatar
    Join Date
    Sep 2012
    Location
    Salt Lake City, UT
    Posts
    851
    Member #
    207
    Liked
    259 times
    Make sure you mark it so it is in phase before pulling the driveshaft apart. Also if you do need to ever change the bearing it has a snap ring that holds it in the shaft it’s kinda a pain in the ass to get to. I doubt your bearing is bad. It’s always the splines. I did the TSB and drilled and out the set screw in because I got sick of taking it apart every 300 miles.

  10. #29
    Junior Member mrclark's Avatar
    Join Date
    Aug 2018
    Posts
    7
    Member #
    49166
    thanks, I tried the hill thing and it was silent. I may not have been going fast enough but it was very quiet. I'm going to make a video of it.

Page 3 of 3 FirstFirst 123

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 8
    Last Post: 03-29-2016, 07:27 AM
  2. Maverick slow out of the box?? Anyone seen this before? Help!
    By Scooter1985 in forum Maverick Discussions
    Replies: 9
    Last Post: 09-17-2014, 07:11 PM
  3. anyone else have rattling issues?
    By lsxzr2 in forum Maverick Discussions
    Replies: 35
    Last Post: 08-11-2014, 06:28 PM
  4. Stock clutch rattle at lower speeds and light throttle
    By SS90 in forum Engine and Drivetrain
    Replies: 2
    Last Post: 05-28-2014, 06:39 PM
  5. (RATTLING) Maverick
    By dirtyj in forum Maverick Discussions
    Replies: 26
    Last Post: 11-26-2013, 04:00 PM