14 Maverick Max R - Loss of Power wont rev
Can-Am Maverick Forum - Powered by vBulletin

14 Maverick Max R - Loss of Power wont rev

This is a discussion on 14 Maverick Max R - Loss of Power wont rev within the Maverick R Max forums, part of the Can-Am Maverick Forums category; I have a 2014 Maverick Max. Back in november I was loading up after buzzing around and noticed that I had two busted axle covers ...

Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Junior Member Gatorbait's Avatar
    Join Date
    Mar 2015
    Location
    Corinth MS
    Posts
    12
    Member #
    5281
    Liked
    1 times

    14 Maverick Max R - Loss of Power wont rev

    I have a 2014 Maverick Max. Back in november I was loading up after buzzing around and noticed that I had two busted axle covers (was running fine). Well life got in the way and I still haven't gotten around to fixing it. In the meantime I have moved it around a few times and it is like it is running in limp mode. I don't have any error messages flashing. If I push the gas all the way down it will barely rev. My belt is in need of being changed, but I wouldn't think that would hold the motor from reving. Any idea what else could be going on. It only has about 400 miles on it (yes seriously under used for 4 years old, bought new old stock in 2015)

  2. #2
    Junior Member fastmontecarlo's Avatar
    Join Date
    Jan 2019
    Posts
    11
    Member #
    50813
    Stupid seat belt limiter pissed me off a few times. Always forgetting about it! No codes is strange

    Sent from my SM-G930W8 using Tapatalk

  3. #3
    Supporting Member
    Premium Member
    Desertdog01's Avatar
    Join Date
    Aug 2018
    Location
    Some where in Santa barbara ca.
    Posts
    1,121
    Member #
    49290
    Liked
    617 times
    How old is the gas?
    Life doesent get much better than eating taco’s down at scorpian bay ,baja sur
    2018 x3 xrs/ smart lok,rugged radios,baga design squadron pro’s,onyx6,afx alum. Lower doors,brp door handles, Evo c/d + tune, wet sounds elite 10, aim belt temp, + way too much to list need more $$ not close to being done

  4. Remove Advertisements
    MaverickForums.net
    Advertisements
     

  5. #4
    Member BRPCare's Avatar
    Join Date
    Nov 2013
    Location
    Sherbrooke, QC
    Posts
    41
    Member #
    2172
    Liked
    139 times
    Quote Originally Posted by Gatorbait View Post
    I have a 2014 Maverick Max. Back in november I was loading up after buzzing around and noticed that I had two busted axle covers (was running fine). Well life got in the way and I still haven't gotten around to fixing it. In the meantime I have moved it around a few times and it is like it is running in limp mode. I don't have any error messages flashing. If I push the gas all the way down it will barely rev. My belt is in need of being changed, but I wouldn't think that would hold the motor from reving. Any idea what else could be going on. It only has about 400 miles on it (yes seriously under used for 4 years old, bought new old stock in 2015)
    Hey Gatorbait. We are sorry to hear this. We invite you to use our online tool at the following link to find your nearest dealer who will be happy to assist you: https://can-am.brp.com/off-road/dealer-locator.html. Should you have any further questions or comments, please do not hesitate reach out again by replying to this message or call us at 1-888-272-9222. Best Regards Anne-BRPcare
    BRPcare
    Social Consumer Experience Team

  6. #5
    Supporting Member
    Premium Member
    DsrtDog's Avatar
    Join Date
    Dec 2018
    Posts
    43
    Member #
    50517
    Liked
    12 times
    Going to go with what FMC mentioned above, have you checked the seat belt limiter ?
    if your driver beltt isnt clicked in or that circuit is interrupted, the thing wont rev.
    Its an $8 bypass ... get a bypass harness on Amazon and it plugs right in.
    Also have the reverse circuit limiter, but there is an override switch for that you can test.

  7. #6
    Member Mudskipper's Avatar
    Join Date
    Jul 2017
    Location
    Pensacola, Florida and Newport Beach, California
    Posts
    87
    Member #
    30233
    Liked
    20 times
    what are busted axle covers ?

    you are latching the seat belt like the others said while in park ?
    2015 XDS TURBO
    MRRPM ecu reflash
    Trinity racing stage 5 full exhaust
    CT Race Worx full shock tune
    EVO silicone turbo hoses and BOV
    EVO cat delete
    Fully wrapped and coated exhaust
    Gorilla axles/rear
    Warrior Riser snorkels
    Alba Racing tie rods
    Alba Racing radius rods
    Alba Racing belt temp gauge
    Rouge Racing mesh hood/side panels
    Wild Boar front bumper
    Front and rear winches
    EMP Racing rear gusset/winch mount
    32 inch Terminators
    Highlifter arched a-arms
    Dragonfire intrusion bar
    Airdam clutch kit

  8. #7
    Supporting Member
    Premium Member
    Tmesic's Avatar
    Join Date
    Oct 2014
    Location
    Surprise, Arizona
    Posts
    5,957
    Member #
    4060
    Liked
    4553 times
    Quote Originally Posted by Mudskipper View Post
    what are busted axle covers ?

    you are latching the seat belt like the others said while in park ?

    Was wondering the same thing. Maybe cv boots? Tim
    Have a rainbowey, unicorny day.

    Love Tim

    Me and My RC , whats good enough for other folk ain't good enough for me.

  9. #8
    Junior Member Gatorbait's Avatar
    Join Date
    Mar 2015
    Location
    Corinth MS
    Posts
    12
    Member #
    5281
    Liked
    1 times
    Sorry guys have been working on other stuff. Yeah the gas is probably old, but this happened all of a sudden between rides with not much time between. Yes it's the CV boots that are busted.

    The seat belt was plugged in when this was happening. How would I go about checking if the seatbelt was faulting it out, and where would I plug the jumper. I do have the seat belt on at all times when riding. It is acting like it does when it's not buckled in.

    Is there a computer scanner tool available to the public to see what is going on with the computer on these.

    I'm pretty sure the screen tells you to buckle up if that is the fault. I'll try it again tomorrow and make sure I buckle before I take off, but I don't think I changed how I do it after all these years.

  10. #9
    Junior Member Gatorbait's Avatar
    Join Date
    Mar 2015
    Location
    Corinth MS
    Posts
    12
    Member #
    5281
    Liked
    1 times
    Friday night I got out and rode about a 1/2 mile and noticed it smelled hot, I turned around and came home. When I parked I noticed the catalytic converter was glowing red. I actually moved it from where I usually park it and moved it to a gravel area in case it caught fire.

    It didn't.

    Well yesterday I pulled the belt housing and the belt looks fine (unrelated to glowing cat converter) the belt looks fine btw but I did have a hole in the hose on the front of the housing.

    Anyway I either have a bird nest in my exhaust or a clogged catilic converter. I'm planning on taking it all apart to see if I can figure out what is going on.
    May be building a cat bypass of buying one shortly. I'd like to quiet it down some, which purchased cat delete pipe setup will give better flow, but still be the same volume or quieter?

  11. #10
    Junior Member fastmontecarlo's Avatar
    Join Date
    Jan 2019
    Posts
    11
    Member #
    50813
    I found the cat delete makes them sound louder, more pop and crackly sounding. I've been told the cats are an issue. Cat delete is on my wish list. Keep us posted!

    Sent from my SM-G930W8 using Tapatalk

Page 1 of 2 12 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 15
    Last Post: 07-16-2018, 04:49 PM
  2. 2014 XRS Power loss
    By blackstang in forum Maverick Discussions
    Replies: 4
    Last Post: 10-16-2015, 09:51 AM
  3. max xds turbo wont rev above 6200 rpm.
    By Denver Broncos in forum Maverick Discussions
    Replies: 16
    Last Post: 08-21-2015, 01:18 AM
  4. Two Brothers slip on power loss/gain?
    By mrtosh in forum Maverick Discussions
    Replies: 5
    Last Post: 05-25-2014, 10:51 PM
  5. Power Steering Power loss
    By HuronKid in forum Maverick XRS
    Replies: 13
    Last Post: 05-02-2014, 08:55 PM