Help!
Can-Am Maverick Forum - Powered by vBulletin

Help!

This is a discussion on Help! within the Maverick R forums, part of the Can-Am Maverick Forums category; so i have a 2015 maverick 1000r and i have come across a problem with it going into limp mode after riding for about 10-15 ...

Results 1 to 5 of 5
Like Tree3Likes
  • 2 Post By Megadesertdiesel
  • 1 Post By Cales

Thread: Help!

  1. #1
    Junior Member KelseyB's Avatar
    Join Date
    Sep 2018
    Location
    Nebraska
    Posts
    6
    Member #
    49634

    Help!

    so i have a 2015 maverick 1000r and i have come across a problem with it going into limp mode after riding for about 10-15 min. if i shut it off and let it sit for a few min it goes away but comes right back after 10-15 min. sometimes it over heats at the same time but not every time. any help to steer me in the right direction to get the issue resolved would be greatly appreciated.

  2. #2
    Supporting Member
    Premium Member
    Megadesertdiesel's Avatar
    Join Date
    Sep 2012
    Location
    Mesa, AZ
    Posts
    6,880
    Member #
    80
    Liked
    4656 times
    What codes are you seeing?

    can you see through the radiator with a flashlight? Could be plugged up.

    have you raised the front of the car to bleed air out of radiator system?
    Tmesic and MN Mav like this.

  3. #3
    Senior Member MN Mav's Avatar
    Join Date
    Sep 2013
    Location
    Northern MN
    Posts
    1,527
    Member #
    1745
    Liked
    189 times
    ^^^^^^^^X2 and check that your fan is running, could also be a thermostat problem.

  4. Remove Advertisements
    MaverickForums.net
    Advertisements
     

  5. #4
    Junior Member KelseyB's Avatar
    Join Date
    Sep 2018
    Location
    Nebraska
    Posts
    6
    Member #
    49634
    i havent had a chance to scan it yet but i will try both of those as well! thank you!
    and yes the fan is running.

  6. #5
    Supporting Member
    Premium Member
    Cales's Avatar
    Join Date
    Jun 2014
    Location
    Central Illinois
    Posts
    1,318
    Member #
    3293
    Liked
    483 times
    This model is known for trapping air in the cooling system. I had a 2014 model and it was very bad to splash mud up and clog the radiator. As Mega said use a light to shine through the radiator. Mine was so hard to keep the radiator clean I bought the BRP removable grill so I could properly flush the dirt out , it would look clean but if I held the sprayer to the radiator mud would keep coming out. If it is mud or dirt blocking the airflow you will most likely have to remove plastic or the radiator to get it clean.
    KelseyB likes this.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Tags for this Thread