Wet sensor
Can-Am Maverick Forum - Powered by vBulletin

Wet sensor

This is a discussion on Wet sensor within the Maverick X3 forums, part of the Can-Am Maverick Forums category; So I have been getting weird codes ( https://www.maverickforums.net/#/topics/117217?page=1 ) and I was cleaning my intercooler so I decided to check the connections while intercooler ...

Results 1 to 4 of 4

Thread: Wet sensor

  1. #1
    Member bobbyj24's Avatar
    Join Date
    Jan 2019
    Posts
    72
    Member #
    50885
    Liked
    1 times

    Wet sensor

    So I have been getting weird codes ( https://www.maverickforums.net/#/topics/117217 ) and I was cleaning my intercooler so I decided to check the connections while intercooler was off and when I took this , what I think is a sensor, off it was a tiny bit wet inside. Dunno what liquid it was but Probably shouldn’t be wet... Was wondering if it has happened to anyone before and what it actually is... on the valve cover ...
    Attached Images Attached Images   

  2. #2
    Senior Member skidoochris's Avatar
    Join Date
    Apr 2018
    Location
    Michigan
    Posts
    891
    Member #
    43634
    Liked
    211 times
    thats the cam sensor
    maybe motor oil
    17 xds, Boondocker turbo kit, Whalen 240xx tune, 3bar sensors, Powervision with AFR logging, AEM 320 fuel pump, Bosch 1200cc injectors, H&H performance clutching and custom tuning, Pro Armor 4 point harness, UMP filter, Evo v flow, fan override, razorback belt gauge, STU 1300x15 Padla comp cut, 31x15 Tribute comp cut on DWT wheels, Tensor 30x10 x14 on MSA wheels or ITP mud lite 30x12x14 on stock wheels and street legal

  3. #3
    Supporting Member
    Premium Member
    Megadesertdiesel's Avatar
    Join Date
    Sep 2012
    Location
    Mesa, AZ
    Posts
    6,714
    Member #
    80
    Liked
    4444 times
    pull the sensor and check to see if its cracked letting oil out. At very least clean it well with some IPA and reinstall to check for a leak again. Then when you find it tight add some diaelectric grease to the plug.

  4. Remove Advertisements
    MaverickForums.net
    Advertisements
     

  5. #4
    Senior Member ferrett21's Avatar
    Join Date
    May 2017
    Location
    Chino hills, ca
    Posts
    594
    Member #
    28290
    Liked
    228 times
    Like mega said, drink a couple IPA’s, maybe a dark beer or two, clean the plug and check again in the future.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. MiMav version Belt Temperature Gauge and Sensor
    By MiMav in forum Audio, Lighting and Electrical
    Replies: 42
    Last Post: 05-18-2016, 01:16 PM
  2. How to clean speed sensor ?
    By RZR Hater in forum Maverick Discussions
    Replies: 10
    Last Post: 04-19-2016, 10:39 PM
  3. Oil pressure sensor
    By Andy in forum Maverick Accessories
    Replies: 8
    Last Post: 08-08-2015, 08:54 AM
  4. Seatbelt sensor removal?????
    By taebroughton in forum Maverick Accessories
    Replies: 23
    Last Post: 08-20-2014, 01:42 PM
  5. Auto meter Sport-Comp Series AFR gauge and O2 Sensor Kit
    By heavysledz in forum Engine and Drivetrain
    Replies: 2
    Last Post: 10-03-2013, 01:00 PM