Turns over but wont start
Can-Am Maverick Forum - Powered by vBulletin

Turns over but wont start

This is a discussion on Turns over but wont start within the Engine and Drivetrain forums, part of the Can-am Maverick Technical Discussions category; ok..I need some help. We recently moved. The X3 never had a problem before. Moved to the new place. Moved it in and out of ...

Page 1 of 7 123 ... LastLast
Results 1 to 10 of 63
Like Tree31Likes

Thread: Turns over but wont start

  1. #1
    Senior Member jchevy4x4j's Avatar
    Join Date
    Dec 2013
    Location
    Roseville, CA
    Posts
    835
    Member #
    2294
    Liked
    315 times

    Turns over but wont start

    ok..I need some help. We recently moved. The X3 never had a problem before. Moved to the new place. Moved it in and out of the garage with no problems several times. Fired right up. Always hooked to a charger.

    Went to go start it again and it just turns over for the 5-10 seconds and wont start.

    - Dual battery's. 12.4 volts to both battery's, even tried starting with a batter charger hooked up. Double checked all connections and they are tight.
    - The big fuse by the battery is good. There is also a 10 amp fuse there that is good as well.
    - Harness to the ECU are solid. Disconnect and plugged back in.
    - Programmed back to stock
    - After programming back to stock, disconnected programmer.
    - Pulled fuel line off and fuel pressure is good. Its flowing fast and steady. Fuse to fuel pump is good.
    - Checked all fuses in the main fuse box. All are good
    - Checked every harness to make sure it is plugged in that I can visually see and get too.
    - tried green and grey key.
    - Tried in every gear position and rocked the car back and forth

    Outside checking for spark or pulling plugs, what could I be missing? Is there an ignition fuse or harness I should check?

    I'm open to any ideas. I scheduled an appointment with dealer and have aftermarket warranty, but believe me, if I can fix it myself I will. Plus the dealer is several weeks out. Such a joke.

  2. #2
    Junior Member Dealtimeman's Avatar
    Join Date
    May 2019
    Posts
    18
    Member #
    52423
    Liked
    3 times
    I would start by changing plugs out first. And get an in-line spark indicator.

  3. #3
    Supporting Member
    Premium Member
    Megadesertdiesel's Avatar
    Join Date
    Sep 2012
    Location
    Mesa, AZ
    Posts
    6,875
    Member #
    80
    Liked
    4651 times
    Fuel at fuel rail? Swap keys?

  4. Remove Advertisements
    MaverickForums.net
    Advertisements
     

  5. #4
    Senior Member jchevy4x4j's Avatar
    Join Date
    Dec 2013
    Location
    Roseville, CA
    Posts
    835
    Member #
    2294
    Liked
    315 times
    Quote Originally Posted by Megadesertdiesel View Post
    Fuel at fuel rail? Swap keys?
    Yup disconnected fuel at fuel rail and it pours out. Tried both keys

  6. #5
    Senior Member jchevy4x4j's Avatar
    Join Date
    Dec 2013
    Location
    Roseville, CA
    Posts
    835
    Member #
    2294
    Liked
    315 times
    Quote Originally Posted by Dealtimeman View Post
    I would start by changing plugs out first. And get an in-line spark indicator.
    Spark plugs are next

  7. #6
    Supporting Member
    Premium Member
    Desertdog01's Avatar
    Join Date
    Aug 2018
    Location
    Some where in Santa barbara ca.
    Posts
    1,737
    Member #
    49290
    Liked
    984 times
    Good luck and let us know , somebody else had a problem like this ,but after doing some welding and his battery getting low some how he lost the marriage of the key to the ecu so had to get them reacquainted so to say
    Life doesent get much better than eating taco’s down at scorpian bay ,baja sur
    2018 x3 xrs/ smart lok,rugged radios,baga design squadron pro’s,onyx6,afx alum. Lower doors,brp door handles, Evo c/d + tune, wet sounds elite 10, aim belt temp, + way too much to list need more $$ not close to being done

  8. #7
    Senior Member jchevy4x4j's Avatar
    Join Date
    Dec 2013
    Location
    Roseville, CA
    Posts
    835
    Member #
    2294
    Liked
    315 times
    I have a few more questions, maybe someone might have the answer too.

    I tried someone else's key and it wont even attempt to start. Wouldn't that be the same case with my keys if they weren't married to my ecu?

    Does anyone have a diagram of the electrical system that supplies spark? Which connectors I need to check?

    Can I just swap out someone else's key and ecu to see if it will start?

    I'm guessing BUDS has a way of seeing what is happening if it was hooked up to the X3 while starting. Anyone close to Sacramento that has BUDS and wants to make some side money :-)

    I haven't had time to pull the spark plugs to see if there isn't spark. I'm just assuming there isn't. I went through pretty much everything else last night.

  9. #8
    Supporting Member
    Premium Member
    mstrav73's Avatar
    Join Date
    Jan 2017
    Location
    Idaho
    Posts
    3,166
    Member #
    23322
    Liked
    1517 times
    I doubt its plugs, I am worried its your ECU. you could at least pull a coil out and put a plug in it to check for spark? I think yes you need ECU and a matched key for it to start, but I have never tried this
    17' triple black X3 XRS - longest lasting SxS I have ever had as it still make me smile every-time I drive it!!

  10. #9
    Supporting Member
    Premium Member
    mgrotel's Avatar
    Join Date
    Aug 2016
    Posts
    6,845
    Member #
    15953
    Liked
    3855 times
    The fact that its not firing at all tells me its not cylinder specific, things like plugs or coils. If it was one of those, it would fire up but have misfires. Fuel is good, I am assuming air is getting into the cylinders, has to be spark related but something that all cylinders share like a map sensor or something all cylinders have in common.
    2017 X3 XRS

  11. #10
    Supporting Member
    Premium Member
    mstrav73's Avatar
    Join Date
    Jan 2017
    Location
    Idaho
    Posts
    3,166
    Member #
    23322
    Liked
    1517 times
    If one coil, plug or cylinder was bad would run like shit but would fire off. I think something with the tune / ECU? just weird it ran fine after moving then wont fire? Did being on the charger blow a fuse?
    17' triple black X3 XRS - longest lasting SxS I have ever had as it still make me smile every-time I drive it!!

Page 1 of 7 123 ... LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. X3RC turns over but won't start
    By Desert RC in forum Maverick X3
    Replies: 3
    Last Post: 11-26-2018, 05:14 PM
  2. Replies: 9
    Last Post: 11-05-2018, 04:01 PM
  3. Replies: 15
    Last Post: 07-16-2018, 04:49 PM
  4. XDS Turbo just shut off and now wont start
    By Ripshua19 in forum Maverick 15-16 XDS/XRS Turbo
    Replies: 8
    Last Post: 06-29-2017, 08:49 AM
  5. "PPS fault" and wont start
    By jonyb in forum Engine and Drivetrain
    Replies: 5
    Last Post: 09-30-2014, 04:29 PM